$re = '/(?<![^\s_-])myspecificword(?![^\s_-])/m';
$str = 'myspecificword
hello myspecificword goodbye
_myspecificword_
-myspecificword-
AmyspecificwordB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);