re = /(?:'(\w+)|\G(?<!^))(?:;(\w+)=(\w+))?(?=.*?:(\w+)')/m
str = '$subject = \'name:content\' ;
$subject = \'name;param1=value1:content\' ;
$subject = \'name;param11=value11;param21=value21:content\' ;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end