# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
<R-PORT-PROTOTYPE .*? <short-name>PQR</short-name>
(?:
(?:
(?(1) (?!) )
.*?
<V>
( .*? ) # (1)
</V>
.*?
<PARAMETER-REF [ ] DEST="PARAMETER-DATA-PROTOTYPE"> .*? MNO1</PARAMETER-REF>
)
|
(?:
(?(2) (?!) )
.*?
<V>
( .*? ) # (2)
</V>
.*?
<PARAMETER-REF [ ] DEST="PARAMETER-DATA-PROTOTYPE"> .*? MNO2</PARAMETER-REF>
)
){1,2}
.*
"""
test_str = (" <R-PORT-PROTOTYPE **************>\n"
" <SHORT-NAME>PQR</SHORT-NAME>\n"
" <REQUIRED-COM-SPECS>\n"
" <PARAMETER-REQUIRE-COM-SPEC>\n"
" <APPLICATION-VALUE-SPECIFICATION>\n"
" <SHORT-LABEL>abc1</SHORT-LABEL>\n"
" <SW-VALUES-PHYS>\n"
" <V>80</V>\n"
" </SW-VALUES-PHYS> \n"
" </APPLICATION-VALUE-SPECIFICATION>\n"
" <PARAMETER-REF DEST=\"PARAMETER-DATA-PROTOTYPE\">**************/MNO1</PARAMETER-REF>\n"
" </PARAMETER-REQUIRE-COM-SPEC>\n"
" <PARAMETER-REQUIRE-COM-SPEC>\n"
" <APPLICATION-VALUE-SPECIFICATION>\n"
" <SHORT-LABEL>abc2</SHORT-LABEL>\n"
" <SW-VALUES-PHYS>\n"
" <V>-80</V>\n"
" </SW-VALUES-PHYS> \n"
" </APPLICATION-VALUE-SPECIFICATION> \n"
" <PARAMETER-REF DEST=\"PARAMETER-DATA-PROTOTYPE\">**************/MNO2</PARAMETER-REF>\n"
" </PARAMETER-REQUIRE-COM-SPEC>\n"
" </REQUIRED-COM-SPECS>\n"
" </R-PORT-PROTOTYPE>\n\n")
subst = "MNO1=$1 , MNO2=$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.VERBOSE | re.DOTALL | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.