$re = '/^.*\/x\+\d*\/.*$/m';
$str = 'abc/x+10/tomorrow
abc/x+10tomorrow';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);