$re = '/\w+[.?!]+\s+(?=\p{Ll})/u';
$str = 'Howdy world? lorem // match (world? should be selected)
Howdy world... lorem // match (world... should be selected)
Howdy world? lorem // match
What is world. howdy // match
Howdy you. Lorem // no match
Howdy you. 進撃の // no match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);