re = /(1?[\(\s\.-]\d{3}\)?[\s\.-]\d{3}[\s\.-]\d{4}(\z[^\d])?)/
str = '(408) 394-7557
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end