$re = '/(\W+|[0-9]+)$/m';
$str = 'support.help1.com,,
support.help1.com.
support.help1.com9
support.help1.com*
support.help1.com@@
support.help1.com##
support.help1.com%%
support.help1.com^
support.help1.com
support.help1.com,
support.help1.com-';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;