$re = '/(A|B)foo(?!\1)(A|B)/';
$str = 'AfooB
AfooA
BfooA
BfooB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);