$re = '/(?<=-)(\d+)/';
$str = '123-418-56-778-91';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);