package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((25[0-5]|2[0-4]\d|[01]?\d\d?)\.(25[0-5]|2[0-4]\d|[01]?\d\d?)\.(25[0-5]|2[0-4]\d|[01]?\d\d?)\.(25[0-5]|2[0-4]\d|[01]?\d\d?)(?:,(25[0-5]|2[0-4]\d|[01]?\d\d?)\.(25[0-5]|2[0-4]\d|[01]?\d\d?)\.(25[0-5]|2[0-4]\d|[01]?\d\d?)\.(25[0-5]|2[0-4]\d|[01]?\d\d?))*|\*)$`)
var str = `192.168.1.1,192.56.3.23,189.35.2.2,198.23.45.56,198.168.1.255
*
Validate IP i.e 1.1.1.1 (Numbers and [.] dot char). Also, “*” alone is allowed
"*" is present, no other IPs should be present.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}