# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^bes|\)$)"
test_str = ("Einer der Mönch saß abgesondert auf einem vergoldeten\n"
"Stuhl in der Nähe des Gouverneurs. Er war der Mittelpunkt\n"
" des Festes, sollte den Ehrenpreis des Jahres für die\n"
"beste Arbeit über die uralten Palibücher zuerteilt bekommen.\n"
"Seinetwegen saßen all die weisen Buddhaväter dort, mit bes\n"
"runden Brillen vor ihren klugen Augen, und warteten auf\n"
"His Honour, der den Preis überreichen sollte: ein gebundenes\n"
"Exemplar von den Werken der gelehrten Gesellschaft;\n"
"die Bücher lagen auf dem Tisch des Gouverneurs aufgestapelt\n"
" und warteten ebenso wie wir anderen.")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.