using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"turn (.+?) (?:the)?\s*lights";
string input = @"turn on lights
turn on the lights";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}