re = /((?<!')datatable)/
str = 'property xxx as datatable
proptery xxx as object \'datatable adasdasdas
\'dim x as datatable
dim x as datatable = new xxxx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end