$re = '/.*((?<!\')datatable).*/';
$str = 'property xxx as datatable
proptery xxx as object \'datatable adasdasdas
\'dim x as datatable
dim x as datatable = new xxxx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);