#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?:\s*([\d\.]+).*"
Local $sString = "PAY VALUES TO SUM - WITHOU NOTHING: 0.00 13º WORD WORD: 0.00" & @CRLF & _
"PAY VALUES TO SUM - ADD. 50 YEARS: 0.00 WORD WORD WORD: 0.00" & @CRLF & _
"PAY VALUES TO SUM - ADD. 70 YEARS: 0.00 WORD WORD WORD: 0.00" & @CRLF & _
"PAY VALUES TO SUM - ADD. 80 YEARS: 0.00 WORD WORD WORD WORD WORD WORD WORD: 0.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")