use strict;
my $str = '/sports/cricket/ipl/top-stories/kxip-vs-csk-shane-watson-faf-du-plessis-infuse-life-into-csks-ipl-campaign-shape-confidence-boosting-win-over-kxip/articleshow/78481088.cms
/sports/football/epl/top-stories/epl-manchester-united-humiliated-as-mourinhos-spurs-win-6-1-at-old-trafford/articleshow/78481304.cms
https://sports/football/epl/top-stories/epl-manchester-united-humiliated-as-mourinhos-spurs-win-6-1-at-old-trafford/articleshow/78481304.cms';
my $regex = qr/(?<!:/)(/sports/[a-z0-9/.:-]*[0-9.]+cms)/mp;
my $subst = 'https://\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";