re = /(^[^\/*+({})-]+|(?:[\/*+({})-])[^\/*+({})-]+(?:[\/*+({})-])|[^\/*+({})-]+$)/m
str = 'abc+1*def
{abc}+1+def
abc+(1+def)
abc+(1+{def})
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end