$re = '~^\d+ - \K.+$~';
$str = '1234 - This is a string with 100 characters';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);