using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\w+\.)+)keys\(\)";
string input = @"assignment_progress_header = ','.join(self.ASSIGNMENT_PROGRESS_STRUCTURE.keys()) + '\n'
j.keys()
adasd.keys()
snallg = pop.keys()
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}