package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^(chr)?(1|2|3|4|5|6|7|8|9|10|11|12|13|14|15|16|17|18|19|20|21|22|X|Y)((:|\s+)\d+((-|\s+)\d+((_|\s+)[ACGT]+((\/|\s+)[ACGT]+)?)?)?)?$`)
var str = `11 12345 54321 a t`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}