$re = '/(?<=\s|^)\d+(?=\s|\b)/m';
$str = '123 My number is +12 345 678. I have galaxy s3, its symbol 34abc 999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);