import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^myfunc\\.call\\(\\{(?:\\r?\\n(?!\\s*(?:\"logging\"|myfunc\\.call)).*)*\\r?\\n.*\"logging\"\\s*:\\s*(true|false)";
final String string = "myfunc.call({\n"
+ " \"logging\" : true\n"
+ " });\n\n"
+ "myfunc.call({\n"
+ " \"logging\" : true,\n"
+ " //\"mode\": true,\n"
+ " }, \"project1\");\n"
+ "myfunc.call({\n"
+ " \"devMode\": true,\n"
+ " \"logging\" : false,\n"
+ " }, \"project1\");\n\n"
+ "myfunc.call({\n"
+ " \"apiKey\": \"xxx\",\n"
+ " \"baseURL\": \"HTTP://xxx\", // url used when not in dev mode\n"
+ " \"mode\": false, // mode\n"
+ " \"logging\": true, // logs events\n"
+ " }, \"project1\");\n\n"
+ "myfunc.call({\n"
+ " \"apiKey\": \"xxx\"\n"
+ " }, \"project1\");\n\n"
+ "myfunc.call({\n"
+ " \"apiKey\": \"xxx\",\n"
+ " \"baseURL\": \"HTTP://xxx\", // url used when not in dev mode\n"
+ " \"mode\": false, // mode\n"
+ " \"logging\": true, // logs events\n"
+ " }, \"project1\");";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}