$re = '/(?<![^,])(?:(?!")[^,\n]*(?<!")|"[^"\n]*")(?![^,])/m';
$str = '2412,21,"Which of the following is not found in all cells?","Curriculum","Life and Living Processes, Life Processes",,,1,0,"endofline"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);