$re = '/^(?=[^a]*a[^a]*$)(?=[^b]*(?:b[^b]*){5}$)(?=[^z]*(?:z[^z]*){7}$).*$/m';
$str = 'uu a uu bb uu bb uu b uu zzzz uu zzz uuuu
one A, five B, seven Z characters';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);