re = /\G(?:, )?\K[\w-]+/
str = 'Wodka, Rum, Gin eigen sich prima für Mixgetränke.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end