package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^123[a-z]3+$`)
var str = `123z33333333333`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}