$re = '/([01]*010[01]*)|([01]+|^$)/m';
$str = '001
0
010
111010
01000000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);