$re = '/^(?=.*[a-zA-Z])(?=.*[0-9])(?=.*[!@#$%*()_+^&}{:;?.])(?:([0-9a-zA-Z])(?!\1)|[!@#$%;*(){}_+^&]){6,}$/m';
$str = 'abc@12
ABc!212
ab@12
aab@12
abc@@1
abc@11
abc12312
@#$!1123
afadf@!!
a1a1@1a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);