re = /[^\[\s](@[a-zA-Z0-9\.\-]+)/m
str = 'Hey @first.last tell [@first.last] to check this out'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end