import re
regex = re.compile(r"(?<![A-z])[A-z]{4}(?![A-z])", flags=re.MULTILINE)
test_str = "salut je m'appell adri et je suis chau"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)