const regex = /^(-?\d*)([a-zA-Z])\^2 *([+-] *\d*)\2 *([+-] *\d+) *= *0$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(-?\\d*)([a-zA-Z])\\^2 *([+-] *\\d*)\\2 *([+-] *\\d+) *= *0$', '')
const str = `-x^2 + 5x + 15 = 0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}