use strict;
my $str = '* DEBUG [2015/11/25 00:06:59] /usr/local/elsa/node/elsa.pl (184) main:: 22497 [undef]
Starting process_batch
* DEBUG [2015/11/25 00:06:59] /usr/local/elsa/node/elsa.pl (271) main::_process_batch 22497 [undef]
Offline processing: and using tempfile /data/elsa/tmp/buffers/1448438819.71967
* ERROR [2015/11/25 00:06:59] /usr/local/elsa/node/elsa.pl (295) main::_process_batch 22497 [undef]
Unable to parse log line: . Only parsed into:
$VAR1 = [];
* DEBUG [2015/11/25 00:06:59] /usr/local/elsa/node/elsa.pl (316) main::_process_batch 22497 [undef]
Finished job process_batch with 0 logs processed and 0 new programs
* DEBUG [2015/11/25 00:06:59] /usr/local/elsa/node/elsa.pl (318) main::_process_batch 22497 [undef]
file size for file /data/elsa/tmp/buffers/1448438819.71967 is 0
* TRACE [2015/11/25 00:06:59] /usr/local/elsa/node/elsa.pl (327) main::_process_batch 22497 [undef]
No logs recorded
* DEBUG [2015/11/25 00:06:59] /usr/local/elsa/node/elsa.pl (188) main:: 22497 [undef]
Processed 0 records
* INFO [2015/11/25 00:07:00] /usr/local/elsa/node/elsa.pl (206) main:: 22497 [undef]
Exiting after processing 0 records
* TRACE [2015/11/25 00:07:04] /usr/local/elsa/node/elsa.pl (135) main:: 22520 [undef]
Processing file __OPS__...
* DEBUG [2015/11/25 00:07:04] /usr/local/elsa/node/elsa.pl (271) main::_process_batch 22520 [undef]
Offline processing: and using tempfile /data/elsa/tmp/buffers/ops_1448438824.46437
* TRACE [2015/11/25 00:07:04] /usr/local/elsa/node/elsa.pl (135) main:: 22526 [undef]
Processing file __IMPORT__...
* INFO [2015/11/25 00:07:04] /usr/local/elsa/node/Indexer.pm (332) Indexer::initial_validate_directory 22522 [undef]
Deleting stale ops log /data/elsa/tmp/buffers/ops_1448438824.46437
* DEBUG [2015/11/25 00:07:04] /usr/local/elsa/node/Indexer.pm (364) Indexer::initial_validate_directory 22522 [undef]
files: $VAR1 = [
\'/data/elsa/tmp/buffers/.\',
\'/data/elsa/tmp/buffers/..\'
];
* DEBUG [2015/11/25 00:07:04] /usr/local/elsa/node/Indexer.pm (366) Indexer::initial_validate_directory 22522 [undef]
considering file /data/elsa/tmp/buffers/.
* DEBUG [2015/11/25 00:07:04] /usr/local/elsa/node/Indexer.pm (366) Indexer::initial_validate_directory 22522 [undef]
considering file /data/elsa/tmp/buffers/..
* TRACE [2015/11/25 00:07:04] /usr/local/elsa/node/Indexer.pm (1782) Indexer::_get_lock 22522 [undef]
Locked directory
* DEBUG [2015/11/25 00:07:04] /usr/local/elsa/node/Indexer.pm (567) Indexer::_validate_directory 22522 [undef]
Wiping via index temp_1
* TRACE [2015/11/25 00:07:04] /usr/local/elsa/node/Indexer.pm (2195) Indexer::_sphinx_index 22522 [undef]
Starting Sphinx indexing for temp_1
* DEBUG [2015/11/25 00:07:04] /usr/local/elsa/node/Indexer.pm (2201) Indexer::_sphinx_index 22522 [undef]
output: Sphinx 2.1.9-id64-release (rel21-r4761)
Copyright (c) 2001-2014, Andrew Aksyonoff
Copyright (c) 2008-2014, Sphinx Technologies Inc (http://sphinxsearch.com)';
my $regex = qr/DEBUG[^*]*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}