#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<th(?:| | .*?)>\s*<a(?:| | .*?)>\s*([\d.]+)\s*</a>\s*</th>\s*<td(?:| | .*?)>\s*stable\s*</td>"
Local $sString = " <table cellpadding="2" cellspacing="1" style="width: 100%; border: 0px;">" & @CRLF & _
" <tr style="background-color: #CCCCCC;">" & @CRLF & _
" <th colspan="5">Available Releases</th>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <th valign="top" bgcolor="#ffffff">Version</th>" & @CRLF & _
" <th valign="top" bgcolor="#ffffff">State</th>" & @CRLF & _
" <th valign="top" bgcolor="#ffffff">Release Date</th>" & @CRLF & _
" <th valign="top" bgcolor="#ffffff">Downloads</th>" & @CRLF & _
" <th valign="top" bgcolor="#ffffff"> </th>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <th valign="top" bgcolor="#cccccc"><a href="/package/APCu/5.1.2">5.1.2</a></th>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">stable</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">2015-12-07</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><a href="/get/apcu-5.1.2.tgz">apcu-5.1.2.tgz</a> (105.7kB)</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><small>[<a href="/package-changelog.php?package=APCu&release=5.1.2">Changelog</a>]</small></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <th valign="top" bgcolor="#cccccc"><a href="/package/APCu/4.0.10">4.0.10</a></th>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">stable</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">2015-12-07</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><a href="/get/apcu-4.0.10.tgz">apcu-4.0.10.tgz</a> (116.5kB) <a href="/package/APCu/4.0.10/windows"><img src="/gifs/windows-icon.png" />DLL</a></td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><small>[<a href="/package-changelog.php?package=APCu&release=4.0.10">Changelog</a>]</small></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <th valign="top" bgcolor="#cccccc"><a href="/package/APCu/5.1.0">5.1.0</a></th>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">beta</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">2015-11-21</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><a href="/get/apcu-5.1.0.tgz">apcu-5.1.0.tgz</a> (106.8kB)</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><small>[<a href="/package-changelog.php?package=APCu&release=5.1.0">Changelog</a>]</small></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <th valign="top" bgcolor="#cccccc"><a href="/package/APCu/4.0.8">4.0.8</a></th>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">stable</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">2015-11-20</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><a href="/get/apcu-4.0.8.tgz">apcu-4.0.8.tgz</a> (116.3kB) <a href="/package/APCu/4.0.8/windows"><img src="/gifs/windows-icon.png" />DLL</a></td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><small>[<a href="/package-changelog.php?package=APCu&release=4.0.8">Changelog</a>]</small></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <th valign="top" bgcolor="#cccccc"><a href="/package/APCu/4.0.7">4.0.7</a></th>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">beta</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">2014-10-11</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><a href="/get/apcu-4.0.7.tgz">apcu-4.0.7.tgz</a> (115.9kB) <a href="/package/APCu/4.0.7/windows"><img src="/gifs/windows-icon.png" />DLL</a></td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><small>[<a href="/package-changelog.php?package=APCu&release=4.0.7">Changelog</a>]</small></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <th valign="top" bgcolor="#cccccc"><a href="/package/APCu/4.0.6">4.0.6</a></th>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">beta</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">2014-06-12</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><a href="/get/apcu-4.0.6.tgz">apcu-4.0.6.tgz</a> (116.9kB) <a href="/package/APCu/4.0.6/windows"><img src="/gifs/windows-icon.png" />DLL</a></td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><small>[<a href="/package-changelog.php?package=APCu&release=4.0.6">Changelog</a>]</small></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <th valign="top" bgcolor="#cccccc"><a href="/package/APCu/4.0.5">4.0.5</a></th>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">beta</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">2014-06-11</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><a href="/get/apcu-4.0.5.tgz">apcu-4.0.5.tgz</a> (116.9kB) <a href="/package/APCu/4.0.5/windows"><img src="/gifs/windows-icon.png" />DLL</a></td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><small>[<a href="/package-changelog.php?package=APCu&release=4.0.5">Changelog</a>]</small></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <th valign="top" bgcolor="#cccccc"><a href="/package/APCu/4.0.4">4.0.4</a></th>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">beta</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">2014-03-01</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><a href="/get/apcu-4.0.4.tgz">apcu-4.0.4.tgz</a> (116.9kB) <a href="/package/APCu/4.0.4/windows"><img src="/gifs/windows-icon.png" />DLL</a></td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><small>[<a href="/package-changelog.php?package=APCu&release=4.0.4">Changelog</a>]</small></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <th valign="top" bgcolor="#cccccc"><a href="/package/APCu/4.0.3">4.0.3</a></th>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">beta</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">2014-01-27</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><a href="/get/apcu-4.0.3.tgz">apcu-4.0.3.tgz</a> (116.9kB) <a href="/package/APCu/4.0.3/windows"><img src="/gifs/windows-icon.png" />DLL</a></td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><small>[<a href="/package-changelog.php?package=APCu&release=4.0.3">Changelog</a>]</small></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <th valign="top" bgcolor="#cccccc"><a href="/package/APCu/4.0.2">4.0.2</a></th>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">beta</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">2013-09-14</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><a href="/get/apcu-4.0.2.tgz">apcu-4.0.2.tgz</a> (117.5kB) <a href="/package/APCu/4.0.2/windows"><img src="/gifs/windows-icon.png" />DLL</a></td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><small>[<a href="/package-changelog.php?package=APCu&release=4.0.2">Changelog</a>]</small></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <th valign="top" bgcolor="#cccccc"><a href="/package/APCu/4.0.1">4.0.1</a></th>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">beta</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">2013-04-30</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><a href="/get/apcu-4.0.1.tgz">apcu-4.0.1.tgz</a> (103.4kB) <a href="/package/APCu/4.0.1/windows"><img src="/gifs/windows-icon.png" />DLL</a></td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><small>[<a href="/package-changelog.php?package=APCu&release=4.0.1">Changelog</a>]</small></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <th valign="top" bgcolor="#cccccc"><a href="/package/APCu/4.0.0">4.0.0</a></th>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">beta</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8">2013-03-26</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><a href="/get/apcu-4.0.0.tgz">apcu-4.0.0.tgz</a> (101.8kB)</td>" & @CRLF & _
" <td valign="top" bgcolor="#e8e8e8"><small>[<a href="/package-changelog.php?package=APCu&release=4.0.0">Changelog</a>]</small></td>" & @CRLF & _
" </tr>" & @CRLF & _
" </table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")