using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^en\s+(.*)\s+(\d+)\s+(\d+)$";
string input = @"en halo%20reach%20noble%20actual%20in%20theater 1 659
en Wazir_Khan_Mosque 2 77859
en Waziristan_War 3 285976
en Wazirpur_Upazila 1 364";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}