$re = '/\d?.{1,}(SL[1-9],)?\w{1,}/';
$str = '14 College Rd, Maidenhead, Windsor and Maidenhead SL6, UK';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);