#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^data:(?<type>[\w\/\-\.]+)?(?:;(?<encoding>\w+))?,(?<data>.*)"
Local $sString = "data:[<mediatype>][;base64],<data>" & @CRLF & _
                "data:,Hello%2C%20World%21" & @CRLF & _
                "data:text/plain;base64,SGVsbG8sIFdvcmxkIQ==" & @CRLF & _
                "data:text/html,%3Ch1%3EHello%2C%20World%21%3C%2Fh1%3E" & @CRLF & _
                "data:text/html,<script>alert('hi');</script>" & @CRLF & _
                "data:image/png;base64,iVBORw0KGgoAA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")