import re
regex = re.compile(r"^[\s\S]{6,64}$", flags=re.MULTILINE)
test_str = ("`1234567890-=~!@#$%^&*()_=\\`1234567890-=~!@#$%^&*()_=\\\n"
"aaaaaaaaaa\n"
"aaaaaaaaaa1\n"
"aaaaaaaaaaa1aaa1\n"
"aaaaaaaaaaa##1\n"
"aaaaaaaaaa##1aaa1\n"
"############11\n"
"^- Actually your requirement :p")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")