re = /(?m)(?:^.*\.$|\([^()]*\)|if\(.*?\/\/endif)(*SKIP)(*F)|\b\d+\b/
str = 'cat 123 sat.
I like 000 not (456) though 111 is fine
222 if( //endif if(cat==789 stuff //endif 333'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end