import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(?:if\\(.*?\\/\\/endif|\\([^()]*\\))(*SKIP)(*F)|\\b\\d+\\b(?!.*\\.$)";
final String string = "cat 123 sat.\n"
+ "I like 000 not (456) though 111 is fine\n"
+ "222 if( //endif if(cat==789 stuff //endif 333";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}