import re
regex = re.compile(r"(?<= )&&(?= )", flags=re.IGNORECASE)
test_str = "x&& &&& && && x"
subst = "and"
result = regex.sub(subst, test_str)
if result:
print(result)