package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`StatementId:[ ](?|\[([^\[\]]*)\]|(.*?)),.*UserId:[ ]([0-9]*)`)
var str = `StatementId: [12345], UserId: 8756
StatementId: 12345, UserId: 8756
StatementId: [12345,6789], UserId: 8756`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}