$re = '~/(?=/|$)~';
$str = '//dir1///dir2/////dir3///dir4///';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;