package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s(?'dup'\w*\s)\k'dup'`)
var str = `This is is a test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}