$re = '/[^\w\s]/';
$str = 'sdfgh, fvgbhnjm
sdfgh wertzukl
sdfgh artsd
sdfgh &fvgbhnjm
sdfgh yxcvbnm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);