$re = '/(?!color: ?)\#(\w+)/i';
$str = '<span style="font-weight: bold;">Heber<span style="color: #FFA500;">[S]</span>ourcE</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);