package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\s*)([-+]?)([0-9,.]+)(\s*)([^-+*\/^])(.*)$`)
var str = `34 +`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}