import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " <p[^>]*>((?:(?!<\\/p>).)+)<\\/p>\\s*<blockquote[^>]*>(.*?)<\\/blockquote>";
final String string = "<p> demo <p>..</p>demo:</p> <p ><img src=\"http://demo.com/123.jpg\" width=\"100%\"/> <br/> <em>Credit: demo2 demo2 </em></p> <p >here1 here1:</p> <blockquote cite=\"here1\"> <p><em>demo3. demo3 demo3 demo3:</em></p> </blockquote> <p >demo4 demo4:</p> <p ><img src=\"http://demo.com/1234.jpg\" width=\"100%\"/> <br/> <em>demo5 demo 5 demo5</em></p> <p >demo6 demo6:</p> <blockquote cite=\"demo6\"> <p><em>demo7 demo7<br/>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}