re = /(?=(G{3,}.{1,7}?G{3,}.{1,7}?G{3,}.{1,7}?G{3,}))/
str = 'GGGTGGGTGGGCGGGAGGG'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end