#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d+\.)?(\d+\.)?(\d+)$"
Local $sString = "3.9.7" & @CRLF & _
"3.9.8" & @CRLF & _
"3.9.9" & @CRLF & _
"3.9.10" & @CRLF & _
"3.10.0" & @CRLF & _
"3.10-dev" & @CRLF & _
"3.10.1" & @CRLF & _
"3.10.2" & @CRLF & _
"3.11.0a6" & @CRLF & _
"3.11-dev"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")