const regex = /(?:\s*(\d+)\s*(?:feet|ft\.|ft|'))?(?:\s*-?\s*(\d+))?(?:\s*(\d+)\/)?(?:(\d+)\s*(?:inches|in\.|in|''|"))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s*(\\d+)\\s*(?:feet|ft\\.|ft|\'))?(?:\\s*-?\\s*(\\d+))?(?:\\s*(\\d+)\\\/)?(?:(\\d+)\\s*(?:inches|in\\.|in|\'\'|"))?', 'g')
const str = `1feet - 2 4/5in
5in
5ft5in.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}